当前位置: 首页 > 默认 > 正文

CentOS6.x将Python2.6.6升级至Python2.7.6方法过程

我们在Linux VPS、服务器中安装软件过程中,需要很多的兼容软件版本,比如老左在尝试宝塔面板的时候被提示需要在Python2.7以上版本才可以安装。我之前在博 客中也有分享过一篇关于这个面板的安装,好像当初在CentOS7.x版本中安装的,因为默认就是Python2.7,所以当时也没有发现这个问题。

这次测试机是用的CentOS6.x版本,默认的Python2.6.6,所以必须升级至2.7才可以,经过测试方法是可行的,然后就就记录下来,下次万一有其他软件也需要这样。但是需要注意,建议我们升级之前如果有重要数据,建议先备份数据,万一,万一,你知道的。

第一、检查当前Python版本

python -V

检查之后,我们可以看到是Python 2.6.6版本,这里老左就不截图了,琐碎的东西太多,就直接把过程记录下来。

第二、升级系统和安装开发工具包

yum -y update
yum groupinstall “Development tools” -y

第三、补充安装需要的组件支持

yum install zlib-devel bzip2-devel openssl-devel ncurses-devel sqlite-devel readline-devel tk-devel -y

第四、安装Python2.7.6

cd /opt
wget –no-check-certificate https://www.python.org/ftp/python/2.7.6/Python-2.7.6.tar.xz
tar xf Python-2.7.6.tar.xz
./configure –prefix=/usr/local
sudo make && sudo make altinstall

注意了,这里是用的altinstall。

第五、检查是否安装

/usr/local/bin/python2.7 –version

目前,我们只能通过这个命令检查,看到Python 2.7.6版本。

第六、创建软链接

mv /usr/bin/python /usr/bin/python2.6.6
ln -s /usr/local/bin/python2.7 /usr/bin/python

移除原来的老版本,然后创建2.7的软链接。这样我们直接用Python -V可以看到已经是Python 2.7.6。

第七、修复兼容问题

这里我们直接执行yum是无法安装软件的,需要修改yum兼容。

vi /usr/bin/yum

编辑文件,在顶部修改成

#!/usr/bin/python2.6.6

保存之后,我们再执行安装,是可以进行的,至少我在原来不能安装宝塔面板的时候,现在是可以安装的,看来升级的Python是有效的。

转自: http://www.laozuo.org/10597.html | 老左博客

发表评论


快捷键:Ctrl+Enter